NME Mathematical Node Different Variable Types

I am looking to do a PR that will make it so you can feed a Vector and a Float into the multiplication node and get the correct output.

It looks like the only thing hindering it is Babylon.js/nodeMaterialBlockConnectionPoint.ts at e32cfdd4eed801dd7475231b607d6b10a0eaceeb · BabylonJS/Babylon.js · GitHub

Won’t let different types be associated, what would be the best way to overwrite for nodes that need to have different types fed to them?

Ideally, we should be able to even do like a vec4 * matrix and stuff.

We have the Scale node for that

1 Like

so why different nodes that essentially do the same thing, but with a limited scope?

And then what do I do about like Fract calculations? do I have to split the vector and do it independently or is there a hidden node besides fract that handles fractioning vectors?

so if we changed:


Will that fix that, off the top of my head that looks like it would.

It is a good question. Some people (like me) prefer to have them separated as they are not the same in the GPU from a perf standpoint. But this is debatable :slight_smile:

it should definitely work!

Trying to do a PR for that, but my CLI is being a asdjklfhasjkldfhjkashf punk.

“remote: Permission to BabylonJS/Babylon.js.git denied to Pryme8.”

I give up I am going to purge my CLI software and the repository from my PC then start over… there is no reason this has been so much of a pain and its like every time I try to contribute my CLI decides it wants to go full reeeeeeee…

this will not get the best of me.

Finally got my CLI working correctly… but should my npm build command take about a hour? @Deltakosh that kinda seems sluggish, prolly a localized problem.

Also why does it just spam base/base/base/base… for ever and ever and ever when its running the tests?

well I’ve just tried from scratch and it worked flawlessly :slight_smile:
Make sure to go to tools/gulp and run npm install then npm run build

It just amazes me how long my CLI takes… like I have been sitting here waiting for it to wrap up for a hot min.

I have followed the instructions verbatim several times and have never gotten this working its to the point where I am about to completely give up ever trying to contribute again because no matter what steps I take I can’t get this running correct. But have no trouble with other projects ever something must be wrong on my client.

Did you start from a clean folder?

yes, I am about to try on my laptop and make sure it’s not just my PC. I have a sneaking suspicion it is my PC there is no reason for the build to take over a hour.

@Deltakosh I think I might be super duper dumb… and was trying to clone the main repository instead of my fork.

Would that make all these issues?

Dunno :slight_smile: We have no clue on what is going on on your side :smiley:

1 Like

its all your fault duhhh…

hold my hand better jeeeez. jk thanks for your help buddy I appreciate you, Ill figure this out.

@Deltakosh it’s actually looking like it might be localized to my PC… hmmm might be time to do a fresh windows install…

mmmkay yeah its definitively localized to my PC, I followed the same steps at the same time doing one on my laptop and one on my PC and got two different outcomes.

Time to purge the PC.

That was surprisingly easy on my laptop…

1 Like


1 Like