Oculus Rift+ WebXR?


I have a webXR experiences in BJS that is working in the GearVr, nut I don’t know how to make it works in the Oculus Rift (not S). Any advise?


Yep - set the xr runtime to rift in your chrome flags, and turn off sandbox mode

Hey thanks for the answer, sorry for my late answer. it’s being very complicated all this days.

So I tried, but I couldnt make it work. I can use webVR app using firefox, but I couldnt make it work webXR with chrome. Any other advice or what am I missing?

these are the settings that work for me. what version of chrome are you using? (also - not that it matters, but you don’t need the AR module on a desktop)

Version 81.0.4044.138 (Official Build) (64-bit).

  1. I start the Oculus app.
  2. I enter to a PG webXR experience.
  3. I press the VR button
  4. I wear my head set

Nothing happen :frowning_face: :sob:

My dear friend,

I am sorry, but there is sadly nothing I can help here. If no XR demo opens up, it is a matter of your system - either chrome, oculus, windows, or all 3. If it is just babylon i can at least debug this, but…

Just try playing around with the flags, make sure to restart the browser and not load from cache. I hope you’ll make it.


I kept trying and I think somehow babylon.js is craching but I dont know the reason look:

Shy it is constantly printing the X and Y. It is not in the PB code, so might be in the babylon.js script?
Why there is a polyfill involve?
How I can help to debug this?

i have no idea why there is apoly fill involved :slight_smile: maybe try a different example without one. the official examples from the doc dont have a polyfill. get a simple scene to work (or fail) from the official docs, and see if it works or not

I got it from official doc!!! but Ill try another one then.

I just deactivate the WebXR plugin and know I dont see the button to get th VR mode. Maybe is related with that?

Also something wierd is that it is never asking for VR permissions as it did it in firefox, is like not detecting my Vr headset?

ha! weird. I will update that. But still - try the simplest example, the sphere. and see if it works.

Chrome only asks once a session if you allow to enter VR, so this is expected.

Not sure what you mean with deactivating the xr plugin. if you mean in chrome 's flas, then this is expected. no XR, no button

the XR emulator for chrome.

That means that chrome doesn’t find an XR runtime, so - something is wrong in the setup. Sorry I can’t help, but you will have to find out what happens on the system. Try the simplest example, try the webxr samples from the webxr repo, make sure they are working correctly.

It is so frustrating. Now I dont know why I have les flags than before and the Oculus WebRuntime is no more available. I didint change anythink. I also download chrme beta, to see if maybe it is posible.

So basically, If I want to develop a WebXR app with Babylon.js which device I have to be able to test without problems?

This is my setup -

  1. Oculus quest using the oculus browser
  2. Desktop Chrome canary with the webxr emulator
  3. Desktop Firefox with the webxr emulator
  4. Desktop chrome stable using oculus rift
  5. (and sometimes) Desktop chrome using windows MR emulator

It all works (usually) without a problem. Chrome changes constantly. Canary doesn’t have the runtime setup, only chrome stable. I never tried canary with the rift, so I can’t comment on that.

As with any new technology, it is constantly being improved and changed. Sadly you are right at a point between two phases. Just try chrome stable again with the rift. Make sure the emulator is NOT installed, because it can mess things up when using it with external devices.

Sorry I can’t help any further. I can only say that this will be stabilized very soon by much smarter people than me.