Potential Bug With Imported .glb Animations

Hi there,
I’m pretty new to 3D modelling and I’ve been playing around with Blender and exporting to GLTF/GLB but some bones are using odd paths to get to their keyframes.
Oddly enough the animations are work perfectly fine when I import into Godot.
I’m not sure how to add a custom mesh to a playground sorry, but if you check the file in the sandbox I’m sure you’ll agree the left leg is taking a less-than-optimal path to get to the next keyframe. Is this a bug or am I doing something wrong?

character.zip (42.3 KB)

Using External Assets - Babylon.js Documentation :wink:

What are you blend export options? I think about animation sampling in particular:
image

1 Like

I can’t believe I didn’t see this, thank you!

And thanks so much for the animation sampling option, I never knew about it before and that completely fixed the issue. Thanks so much!

So this obviously isn’t a bug but user error.

Just thought I’d add I looked at the Blender GLTF exporter repo and this is a common question people have, and will be set to true by default in 2.81. Hopefully that means there won’t be any more silly questions like mine on here :sweat_smile:

1 Like