Problem with alpha transparency with Blender exporter

Hello,

I have a problem exporting an object with Blender 2.8.
I put alpha transparency and rendered with Blender is correct.
After export with version 6.2.0, I can not find transparency in the sandbox.
I attached the zip file of the export: chambrage5c.zip
What’s wrong ?



Exporter log file :
xporter version: 6.2.0, Blender version: 2.80 (sub 75)
========= Conversion from Blender to Babylon.js =========
Scene settings used :
inline textures : false
Material Type : PBR
Positions Precision : 4
Normals Precision : 3
UVs Precision : 3
Vert Color Precision: 3
Mat Weight Precision: 2
texture directory : D:\guide_de_la_mecanique\LE_GUIDE\Les_animations_edge\formes_techniques\chambrage\blender
Python World class constructor completed
processing begun of mesh: Cylinder.001
processing begun of material: bleu
processing begun of material: rouge
processing begun of multimaterial: chambrage5b.Multimaterial#0
num positions : 1002
num normals : 1002
num tangents : 0
num uvs : 0
num uvs2 : 0
num colors : 0
num indices : 4476
processing begun of mesh: Cylinder
processing begun of material: bleu
processing begun of material: rouge
processing begun of material: bleuAlpha
processing begun of material: rougeAlpha
registered as also a user of material: rouge
processing begun of multimaterial: chambrage5b.Multimaterial#1
num positions : 1002
num normals : 1002
num tangents : 0
num uvs : 0
num uvs2 : 0
num colors : 0
num indices : 4476
processing begun of camera (ArcRotateCamera): Camera
WARNING: Camera type with mandatory target specified, but no target to track set. Ignored
processing begun of light (DIRECTIONAL): Lamp
========= Writing of JSON file started =========
writing mesh: Cylinder.001
writing mesh: Cylinder
========= Writing of JSON file completed =========
========= end of processing =========
elapsed time: 0 min, 0.31 secschambrage5c.zip (31.4 KB)

pinging @JCPalmer

At first look, the inspector does set transparency mode to Alpha Blend. As your .blend properties indicates, the exporter is not using the Blender property. The property is slightly different, but the big thing was the default for culling is backwards. This is a major performance issue, so just wanted to ignore everything in that “Settings” section.

You passed the .babylon file, not the .blend, I do not really read JSON. One thing to make sure of is, does this blend work with the scene clear color? In my limit use of this, I have always had another material / mesh I was blending with. @Deltakosh or @sebavan, a ruling of whether PBR alpha blending works with scene clear?

Assuming yes, also make sure that you have alpha in your base /albedo or albedo texture. I did one about an hour ago with just a base color. When you reduce alpha from 1, half the swatch gets a checker board. Starting to see why I decided not to use the Blender properties, though the glTF does?

Yup blending works with the clear color as well in the exact same way for PBR.

Hello,
Thank you for your reply.
I did not see that I could adjust transparency by setting the base color.
Image%202
It works.


Thank you.

1 Like