Rendering Group ID not working on imported mesh

Hello everyone, I have been having trouble rendering the imported meshes in the scene in front of a plane.

For some reason I am unable to iterate through the meshes either in the playground, however I am able to do so in my local copy of the scene. I want the meshes in the scene to show up in front of the plane which has a texture on it which appears when you click the button in the scene. I have tried using renderingGroupId for the same in my local copy but it has not worked for me. I have also checked a similar question on the topic and tried indexing the submeshes of the parent mesh and setting their rendering ID but that hasn’t worked for me either.

Any help will be appreciated!

Hey there, you can render the imported meshes after the plane like this for example. ImportMesh has the on success callback that you’re I think trying to use, not ImportMeshAsync, so I changed it to that. Also by default only 4 render groups are supported (0, 1, 2, and 3), so setting it to 4 wont work. So I just set all the imported meshes to 1 and let the plane default to 0. :slight_smile:


You can use rendergroupId set to 4 as long as you call BABYLON.RenderingManager.MAX_RENDERINGGROUPS = 5


Thank you so much for the help!