Sandbox Inspector not opening for textures

Hello everyone,

I was recently working with some GLB models and wanted to check the textures of my models on Babylon’s sandbox.

For some reason when I open the inspector and click on one of the textures the inspector disappears, I tried on different models,different browsers and on a different computer but I was still experiencing the same issue, I would like to know if this is a bug everyone is facing currently for the sandbox.

me too. I can not open glb material inspector in sandbox.

The bug relates not only to Sandbox, it happens with Inspector in other cases as well.

Would you be able to provide a model which does not work?

I tried with 3 or 4 models and couldn’t make the inspector crash.

Here is the video illustrating the problem.
All is OK when I open meshes. When clicking on material, the right Inspector pane disappears.

1 Like

This is exactly what I am experiencing thank you for providing a video!

what are the file extensions you used? I was testing with gltf models and glb models

Sorry for the trouble, it’s the new decal map feature which introduced a bug with the inspector. This PR will fix it:


Just of curiosity, what does the new decal map plugin do?

It is adding decal map (texture) support to Babylon.

See Material: Add doc for Decal Map by Popov72 · Pull Request #785 · BabylonJS/Documentation · GitHub and Another take at decals. Before talking about the real subject… | by Babylon.js | Medium.


as i am using the viewer to test the material with my glb,
may i know when it can be fix, or anywhere i can use the last version?

It will be deploy in maximum a couple hours @RaananW is deploying as we speak.

should be fine now


Anyone to mark this as fixed/closed? I believe it is. @carolhmj

yep it is thanks for the reminder :slight_smile: