Skeleton issue from Mixamo to blender

Hey,
I tried loading a custom bot in blender by adding animations from mixamo, but after importing it to blender and playing the animation the bot is acting weird the hand bones are getting immersed into body, Can you help me out with this.

Is that a blender question? If so you should post it on Blender forums:)

Let me know if this doesn’t work for you

As @Deltakosh says, it is not obvious if this is even a BJS problem - just no detail apart from"hand bones are getting immersed into body".

Is the character mesh one that you built and imported into Mixamo? In which case the setting up of the rig in Mixamo may be an issue as you have to chose some points for the “Auto-Rigging” process. (See Image below). Are the hips wider than the shoulders - I’ve seen odd results with rather fat characters?

@gbz I think that document needs updating as the latest version of @JCPalmer 's babylon exporter is no longer : Babylon.js ver 6.2.3.

Stay Safe All, gryff :slight_smile:

mixamo01

I’ve followed that doucment from babylon, eventhough same thing is comming up


This is what happening, can you help?

I can try looking into this

Can you share the Blender file and your model’s file and tell us the title of the Mixamo animation you’re trying to add?

1 Like

@vijaynigilesh : As @gbz says can you post the Blender file and the FBX file with the animation from Mixamo

Stay Safe All, gryff :slight_smile:

Its saying i cant upload the file as i’m new user here, do we have any alternate way to send?

You could try adding your files to a GitHub repository and share a link to that

Here is the gltf file and from mixamo you download wave and standing idle animation

please me know if you get something

Will take a look at this over the weekend

@vijaynigilesh : Well, I grabbed your file to take a look. No .blend file or Mixamo ,fbx file, just a gltf file. Anyway, I imported it into Blender 2.93 then exported it as a .babylon file . Here is the playground result using that .babylon file:

Sofia Playground

The animation is just an “Idle” and is kind of slow, so I changed the last number in line 53 from 1 → 1.5 to speed it up. Change it back if you like. Seems to work OK. At 400 frames of animation, it does seem rather long.

I don’t see the issue with the arms you saw in Blender or in the playground.

I will post a couple more thoughts later this afternoon - I have to go walk a dog,

Stay Safe All, gryff :slight_smile:

1 Like

@vijaynigilesh : OK dog walked - so some more thoughts using the images below

Images 1 and 2:
Note the C to set armature positions (pose and rest positions).
This is the figure in its starting pose. (Image1)
This is the figure in its “rest pose”. Never seen a rest pose like that. Mixamo figures and animations typically are in a T-Pose. (Image2)

Images 3 and 4
Bone names and mesh names. Often Mixamo bone names have “mixamo.” at the start of the bone name (A) - yours do not. And you have 82 bones whereas Mixamo rigs typically have 62-67 bones. Nearly all your mesh names start “Wolf3D” (B) - are they meshes (and possibly a rig) from Wolf3D

I can only guess at your workflow, but did you try to add an animation in Blender from Mixamo to a rig and meshes from Wolf3d?

Something is not right with that rest post but I don’t see this crossed arm issue you describe above!

Stay Safe All, gryff :slight_smile:

Image1:

Image2:

Image 3

Image4

1 Like

Thank you, for this but if you add one animation it is working fine then i tried adding two animation one is standing idle and other is wave, then hands were misplacing, can you please try that?

@vijaynigilesh : Well, rather than messing about with a skeleton that has 80+ bones and a very strange “rest” pose - the best solution seemed to start your procedure from scratch by creating a model to upload to Mixamo and then get a proper Mixamo skeleton. That is what I did :

Sofia

Three animations, from Mixamo, chosen at random - click the buttons.

Your model now has a proper A-pose from Mixamo, for a rest pose

I will post some files later today for you to use.

Stay Safe, gryff :slight_smile:

Your model in Mixamo:

@vijaynigilesh : Here are the files I promised - 2 blend files inside the zipped file :

New Sofie Zipped

Open the link in a New Tab and click Download button.

Sofie02a : This file contains the meshes I extracted from your file and fixed the position and rotation - tweak if you like but always make sure to return the origin to the cursor before you use it further. It contains no skeleton! Export this from Blender in a format that Mixamo can use - I exported as an object file. Follow the Mixamo procedures for rig set up then add an animation. Export from Mixamo as a .fbx file with the body. If you are exporting an “idle” animation with lots of keys you might want to consider reducing the keys.

With this Mixamo animation file downloaded import it into Blender with the settings in Image 1 below. Once you have the ,fbx file loaded into Blender, in the Animation Window check the little white shield - so it goes blue and save your blend file.

Create a file like this for each animation you downloaded - so if you download 5 animations create 5 separate blend files. Now chose one of these files and “Append” the “Action” from each of the other files - making sure the little shield is a blue colour and that each animation has a “F” in front of it.

If you exported the file for Mixamo from "Sofie02a.blend as an .obj file - you will have no material in your file. To get over this, “Append” the materials from the original Sofie02a file and assign them to the appropriate meshes.

Now export to babylon.- done :slight_smile:

Stay Safe, gryff :slight_smile:

Image I : Import .fbx file settings :

Image 2 : Final file with 3 animations used for the demo

thank you gryff, for letting me know all this actually the unusual bone rig is because i’ve downloaded the bot from readyplayerme and then imported to blender, i’ve also tried to add lip sync and blink for this bot but i failed can you please guide me how to add those to the bot, which will help me.

Thank you!

@gryff @gbz can you help me with that above issue, I tried lip sync her jaw is moving but her lips her not, same goes with eye blink, will you look into it please??