SSAO is not behaving

So trying to pick up some Babylon.js development again , never got far last time , but decided to look a bit deeper this time.

So SSAO is used in all games / good 3d scenes , there might be some edge case stuff where it is not based on art style or baked AO but otherwise no scene can do without it.

I tried to use it on your engine and was greeted with this black volumetric perlin cloud type noise floating in the middle of my scene. Please tell me im doing something wrong. I tried v1 and v2 and every combination of settings on the sliders… it just always looks like no other AO ive ever seen in a 3d scene in my life. Completely unattached to its surfaces ( i know it is screen space ) I think it is a lag in update between the postprocess and the geometry. (I have a RTX 2060 , 32GB ram i7 - so its not my machine )

here is a video showing what im seeing :

someone please tell me im doing something wrong and tell me how to fix it.

thanks

Indeed this looks weird adding @julien-moreau who knows a lot about this Post Process.

Maybe you could share a repro to help us play with it?

Thanks gents , Deltakosh : I sent the .glb to you in a PM as I cant share it public. In the video all I did was open the online sandbox , drag in the .glb and then in the inspectors on the left added the SSAO. That is all. I made the .glb with blender 2.82. if that helps anything.

I am coding this apart from the sandbox , but I use the sandbox to test values to use in my code as all the inspectors are very handy for that.

cheers

The repro is not for me but for @julien-moreau

Doh haha ok will pm there , sorry about that

2 Likes

Hey! Received the model and tested the SSAO1 and SSAO2

The SSAO1 is based only and only on depth informations and is not intended (unfortunately) to provide high quality results.

The SSAO2 is more powerful and takes advantages of draw buffers. @Deltakosh in the sandbox I noticed that the inspector creates the SSAO1 rendering pipeline neither you select SSAO or SSAO2.

@shaderbytes I think the SSAO2 will look good enough for you, I tested your scene with and the result is awesome :slight_smile:

2 Likes

Thanks Julien-m

Your help and input is very much appreciated. I will just use V2 then , coding it directly in my app without using ssandbox first for testing, well at least for this issue that is. Sandbox is still very very useful to me to establish values for things im coding.

I still have a way to go with porting a biggish application so i will probably get stuck somewhere along the line again and be back … but I will try sort things out by my self and with docs and playground before I do that.

Thanks again everyone.

chat soon

Fixed :slight_smile:

2 Likes