Suddenly 3D buttons doesn't return to initial color in AR

Hi, not sure if this is a bug but I suspect it being the case since I have no other explanation.
When in AR on my Galaxy S21FE: Suddenly my 3D buttons does not return to their initial grey color when pressed. Instead they stay red once pressed.

I’m 99% sure this did not happen two days ago… And I couldn’t figure out anything else apart from that the Babylon version in the Playground seems to have changed the last day.

Has something changed with how the 3D buttons work in this new update?

Babylon.js Playground (

cc @RaananW

This is probably related to a bug that was fixed yesterday. it should be included in the latest minor version (5.49.0)

Do you mean that there is a known bug introduced in 5.49.0? I just tried it in 5.49.0 and the issue is still there.

cc @PolygonalSun - could that be related to the bug fix from yesterday?

Shouldn’t be, the only things that I fixed yesterday were related to PointerDragBehavior and an unrelated flag in the InputManager. I tried removing my changes and saw the same behavior.

did anything change lately, related to pointer up behavior?

AFAIK, the last change made to pointer up behavior (outside of the change I’ve made to ExclusiveDoubleClickMode) probably would have occurred 3 weeks ago.

i’ll run a few tests tomorrow, but will be great to know which could have influenced simulated pointer down and up events.

Hey @RaananW, were you able to find anything?

Yes, sorry!

This is a mobile-only issue. The issue is the pointer-out event which is only being triggered on touch devices, but not on touch-devices that are mobile (i.e. - ar on an android).
I’m searching for a solution :slight_smile:

1 Like

[XR] Fix pointer out event on 3D GUI in XR (mobile ar) by RaananW · Pull Request #13625 · BabylonJS/Babylon.js (


Thank you so much for the fix!