webXR never shows icon in bottom right

I tried everything I know to get the oculus quest 2 to work with a PG that is using webXR. I never see the icon on the bottom to go into the headset mode.

WebVR works no problem, any idea?

cc @RaananW

I am kinda done for today, but is it just one PG? Probably want to post a link if it is just one.

If all, I think you are doing to want to do remote Chrome debugging. You can then view the console log on your desktop. You probably want to have that process set up anyway, if you have never do that.

@JCPalmer Ill hit you up tomorrow about it.

And it seems to be all the webXR examples that I have found.

WebVR on the quest falls back to WebXR (as WebVR was removed a long time ago), so WebXR does work, it seems.
Now, we only need to understand why the default demos don’t show the icon (which means that webxr or this session mode are not available).

Have you tried the default XR demos on the playground?

Hi @Pryme8 just checking in how’s the situation there :slight_smile:

I ended up having to go to other topics for work so this went cold for me, id have to go back and get into it again to have anything to contribute on the topic @carolhmj

1 Like