WebXR/Oculus rift s, works on official webxr website, but doesnt work on babylon examples

Hello, this morning i tried randomly to use webxr on my oculus rift s,

it work from those examples:

but from the ones on babylon, it doesnt, its loading infinitely.

Pinging @RaananW for help/thoughts


When you say

What do you mean exactly? I had the oculus runtime show an hourglass and the first frame, and then not entering the scene from time to time. restarting mostly solved it, but i always thought it was a local issue (as my oculus quest displays everything correctly, and so does my MS MR device). Can you confirm it is the same behavior as I am experiencing? What demos did you try loading? It does feel like an isolated Oculus-Runtime issue, but I want to make sure it is working for sure.

Maybe start with the most basic scene, from doc, that is possible,

then work your way up. If this does not work, then you definitely need to look at the console.

If it does work, then listing the urls seems like a good idea.

you are right the most basic one works well