Why bright border line in SSAO2?


Please take a look at the images below. There is a bright border line between base cabinets and floor. But SSAO2 itself (second image) looks good. Are there any way to eliminate those bright lines between geometries? I’m not using pre-pass mode. All other settings are almost defaults.


Would you have a repro for it? It’s hard to tell without it, as the SSAO itself seems ok, as seen in your second screenshot.

Thank you for your replay. The scene is the procedural model, and it’s hard to make a functional repo. I just hoped that someone who faced similar issue can give me advise.

Perhaps try the prepass renderer instead of the geometric renderer, as prepass uses floating-point textures by default, whereas the geometric renderer does not.

Yes, I’ve tried to use prepass renderer with the same visuals. It looks like the border appears where ibl lighting affects floor and/or toe-kick (See image below).

Bypassing blur removes those light lines, but inroduces a noise instead.


It seems to be a side-effect of the expensive blur (tested with this PG):

Without expensive blur:

With expensive blur (default settings):

With expensive blur (updated settings):


You can therefore try modifying the parameters to reduce artifacts.

1 Like

Alright, thank you for your help.