3dsmax Exporter - Unlit on glTF Material sets Albedo to black

When exporting to .glb in 3ds max 2023 using Babylon’s max exporter, glTF materials set to “Unlit” will become exported with the albedo set to completely black. This makes the materials appear black, and manually setting albedo to white is required to fix this.

Albedo does not turn black when using a PhysicalMaterial set to “Unlit” under the Babylon Attributes.
Neither does it turn black when using 3ds max native glTF exporter.

Only the glTF Material has this erroneous behavior.

Since Autodesk made some changes to the glTF material in the latest 3ds max update I think a bug might have happened in the Babylon exporter.

Can you provide a max file for repro? Thanks.

What max version do you prefer?

I don’t think it matters too much as long as it repros. cc @PatrickRyan

@DanielSwahn, we have access to most of the latest versions of Max, but I would suggest 2023to make sure we are testing out the latest version that the exporter supports.

@PatrickRyan , here is a very simple scene:
unlit_error_box.zip (30.3 KB)

• It contains a box primitive with a glTF material set to “Unlit”.
• The Base Color is set to white, so the appearance in max is an unshaded white box.
• Use the Babylon Exporter, export as .glb and make sure that KHR_materials_unlit is checked.

When viewing the .glb file the Albedo colour is set to black, which just makes the box appear completely black.

If a bitmap is assigned to Base Color and Albedo is set to black the bitmap will not be seen as the Albedo multiplies the bitmap to black.

Albedo should not be set to black when “Unlit Material” is enabled.

I don’t know if this is something Autodesk needs to fix, or the Babylon exporter needs updating, but thought it was worth bringing up.

@PatrickRyan Do you mind checking it out?

@bghgary, I’ll take a look.


I can repro the issue with our exporter and glTF Material using unlit. The other two materials (PBR Material and Physical Material) both export unlit correctly, but glTF Material does not.