BUG?:: Display of "parent" in "the Inspector" shows parenting that has not been set


I don’t know if this is a bug but if it has always been like this, I believe I would have noticed it.

From my (poor) understanding, “parent” is supposed to create a root in the hierarchy and all children of this “parent” should show under the parent and be affected by any change to the parent.

As I was debugging an issue in my scene this morning, I suddenly realized that from the inspector, all my meshes show in the inspector/parent as parented to one of my 3D GUI anchor. At first, I thought this was an error in my script, so I loaded an earlier scene that did not yet have the 3D GUI and all my meshes, according to the inspector, show like they are parented to the ‘camera’??!

So, I thought it could be because of the layerMask and removed all of layerMask but it didn’t change anything. So, I loaded other projects and earlier version scenes of this project but, still all of my meshes in scene show like they are parented to something. Finally, opened a PG from the doc (this PG) and noticed that everything from this very simple scene shows like it is parented to something (the light, the ground…). Though it isn’t and it also does not show like it’s parented in the nodes hierarchy.

Could yours please kindly investigate on this and let me know (if I misunderstood something and never noticed that – or – if this (apparently fairly new) behavior of the inspector can be considered a bug)? Thanks and meanwhile, have a great day :sunglasses:

To me, it looks like a display bug with the combo box
even the default playground shows my ground is parented. but a console.log(ground.parent) displays null.
can you confirm @carolhmj ?

Oh you’re right, that’s super weird! :open_mouth: I’ll investigate immediately.


Yup, it’s definitely a bug, I can confirm the previous version didn’t have this. Looks like it’s related to some changes that were made for the GUI editor, let me see how to best solve it.


Fiiiix here Some fixes to OptionLineComponent related to wrong parent info showin… by carolhmj · Pull Request #13026 · BabylonJS/Babylon.js (github.com)


Thank you. :hugs: You are always so fast to react.:smiling_face_with_three_hearts: Sometimes makes me wonder how you do it and then… why am I so slow :wink: :thinking: Have a great day :sunglasses:

We just always check the forum, it’s part of the job :stuck_out_tongue: And we’re happy to solve things as fast as we are able to :smile:

1 Like

Well, if so :wink:, may be you can solve this one for me. It might be related to the above and then, may be not:

As of yesterday, my instances created from an obj mesh with a scaling of -1 (on any axis) do not render anymore. Fancy thing I noticed is that:

  1. this does not happen with a clone (only an instance)

  2. when from the clone version, I select the default fallback material, it shows like it’s linked to my advancedDynamicTexture (obviously, it isn’t). This is why I thought it might be related but then, as I said, may be not.

It started happening from yesterday. Before that, everything was fine and I didn’t make any changes that could impact this.

I’m using the default left-handed system with obj file loader (from a c4d export). Tried to change the axis of the model to -z…, even tried other (weird) alternatives but nothing does it.
Should I post a new bug for this or do you think this could be somehow related?

SS1: non-rendering instance with minus z (but minus on any axis does the same, instance does not render)

SS2: replaced through clone version (does render normally); However, switched material to default fallback and now shows weird assigning of default material

Hmmmm yesterday’s fix hasn’t been deployed yet, so nothing should have changed, but let me investigate :thinking:

Hmmm I tried reproducing this with some test models but couldn’t get it to happen: Test cloning and instancing | Babylon.js Playground (babylonjs.com) I wonder if it has anything to do with how your model is setup, parenting and all? :thinking:

well, I also did simpler tests in the PG but couldn’t reproduce.
My point is that until yesterday everything was working perfectly. So something must have occured since then.