Color of just one layer is wrong on Export to GLB

Can’t for the life of me figure out why the color of this one layer doesn’t export correctly. The sand is sand color in blender, but black in GLB. Where every other layer is exporting correctly. Any ideas? Is there just some property i’m not checking in blender or something?

Are you putting it into emissive ? :thinking:

Your mesh is declared to use vertex colors but the colors are all black. If you disable vertex colors it’s ok:


Thanks! Never would have guessed that.
So - “useVertexColors” is set in Blender? When i look at the material settings in Blender it seems like it is using an image texture. There’s some other setting that over-rides that?

I have no idea, I don’t know Blender at all, so I don’t know what triggers the export of the vertex colors in the .glb file…

@PirateJC might know ???

Hi. Blender stores and exports vertex colors (for formats that support them) via Mesh Color Attributes data-blocks. To visualize a color attribute in the 3D Viewport Editor, add a Color Attribute Shader Node to an object’s Shader Material.

NOTE: Blender doesn’t need a Color Attribute node to export vertex colors - it exports the Color Attributes data-blocks by default, not the nodes.

If you’d prefer to disable the default exporting of vertex colors, you can do so through the Blender glTF 2.0 export settings panel.