Desktop Editor is Saving Project Incorrectly

As a Unity user I was pleased to see that there is a desktop version of the Babylon Editor. However when I attempt to save my project I get strange results. I can reproduce the bug by doing the following…

  • Open the editor
  • Select New Project
  • Import an Obj and a file
  • create a material that uses the dds texture and apply it to my obj
  • Add a cube mesh
  • create a new texture that uses the same as source.
  • create a new material that uses the same as source
  • Apply the new material to the cube and scale up (creating a skybox)
  • save the file and exit the editor.

Now when I re-open the project the obj no longer has my material applied but the cube (my skybox) does. Furthermore I can make additional changes and re-save and exit. When I re-open the editor it’s as if some changes have been saved and not others. My obj remains un-textured. Am I missing something here? Using editor version 3.2.0, windows 7. Many thanks.

Hello and welcome

Pinging @julien-moreau who is the boss and owner of the editor

1 Like

Hey @TheMissingRobot!
Thanks for reporting! I reproduced and the bug comes from the OBJ workflow of the editor. I’m fixing and will release ASAP :slight_smile:

Thanks @julien-moreau! Looking forward to it! :slight_smile:

I am also new to Babylon.js & the Editor. I’ve tried the editor on two machines, both Macs; In both cases I’ve tried starting with the demo scene, making a few mods, saving as…, quitting and reloading, all per the workflow tutorial found in Resources. In every case no actual changes to the default scene seem to have “stuck” when I reload the scene. And when I load the second scene (again, following the Workflow Tutorial – 2nd scene based on “New Scene” with fresh assets), I get some errors and the preview window shows the same old default scene – but when I run it, some, but not all of what’s supposed to be there is, other stuff is just AWOL.

macOS 10.12.6 (both machines)

Pinging @julien-moreau

Update / after further experimentation : it turns out opening the project DOES open the correct saved project, at least the first scene I saved, when using Project>Import Project… from within the editor-- versus launching the editor by double-clicking on the saved .editorproject scene file in the Finder (which is what I interpreted the Workflow Tutorial to be recommending).

Side note: why is this Project menu item called “Import Project…” instead of “Open…”? Isn’t the operation in fact opening and loading an .editorproject file?

The second scene I saved and tried to load bombs out with a null reference error. In this scene I started with “New Scene” added a cube and a backdrop object, and that’s it. ¯_(ツ)_/


You can find the preview version here:

The workflow is changing a little bit. The editor doesn’t work with deltas anymore. Each scene you import will be added the the “Meshes” assets tab and will be fully handled by the editor (means it makes a copy). This reduces the possible errors coming from loading/saving scenes.
Now, EVERYTHING is saved in the editor project (including geometries).

The goal is to do like all other IDEs like Unity or Unreal :slight_smile:

A Youtube video tutorial is coming soon!

Seen your other post and thanks a lot for all these feedbacks! I’m working hard on this new version to avoid these saving/loading errors and make this editor a real editor instead of a “compute deltas editor”. That means it is becoming a real editor where you can edit everything and create all your scenes like a real editor.

@julien-moreau That is awesome! Many thanks for working on this! Looking forward to trying it out.

1 Like