Earth³ - Interactive solar system

I love this. Creative, inspiring, educational, and entertaining. Great work, and thank you for sharing!

Hello again @Guigoz,
I’m back to you with a final temporary early-alpha version of your featuring;) We all know that only temporary stands over time so, in this time laps, I quickly wanted to check with you, for approval by the administrators of 'The Cube Earth Society, that I did not make an abuse of the Earth3 license and, overall, that my visual representation of our System in the living room correctly considers both the LoLFactor and Kid’s perspective. You see, I don’t want to be the one spreading fake news about the real scaling and position of our planets in the lounge area.
Your comments or amends (as per the SS below) are welcomed before launch. Expected somewhere between today and tomorrow (North Africa Time;)

Meanwhile, have a wonderful day,




Note from legal: The disclaimer, demo intro section, includes the following content as per the use of your license (please amend or approve):
“This demo features some work from the BJS community: ‘Earth3’, ‘The Cube Earth Society’ and the Earth3 cushion and theme design created based on the imagery of ‘Project Earth3’ wallpapers, courtesy of @Guigoz.”

2 Likes

1 Like

FYI, the demo is now live (for desktop only at this very moment):
‘media-geneva.ch/demos/bjs/chair/project-chair-alpha.html’
I will gladly take your comments…
Have a great WE,

Great work, mawa… a small and impressive hint of your talent gives me a feeling that there is much much more behind… :slight_smile:

image

Hi mawa,

I don’t have any GUI except for the upper right controls is that normal ?

I can change the background by pressing “Q” but that’s all :x

Certainly not normal.
I had an issue on Chrome in Bootcamp/Windows on my MBP with Radeon. A rescaling problem I also experience regularly with games. I need to check on this. What is your config if I may ask?

I use chrome in Windows 10 and I have a nvidia 2080Ti
I also have a 4K screen, maybe it’s a problem ?

it’s a scaling problem for sure. I must have missed or f***ed something (may be when detecting mobile). I will look into this over the WE. Thanks a lot for your input, it really helps… I’ll let you know when you should likely be able to see the scene correctly. Meanwhile, may I recommend to try Edge or FF. I did not experience the same scaling issue with these browsers. Hopefully, it will be the same for you?..

I already tried firefox, same problem :x

oopsie;) will be back…

Hi @Guigoz,
I just got the answer. Was easy to find. An unfinished piece of biz;)
I used a DAT Gui during dev. Not configured properly. I thought it would be ‘smart ass’ to keep it on early alpha and just apply a ‘display=none’ to the DOM element. What a shit idea;) It did indeed f*** my html as one would expect. I did the quick fix of removing the crap. Sadly, right now this also means that you cannot adjust the level of PP exposure & contrast because the (very basic) graphic settings panel is not done yet. I will rush it today or tomorrow. Not as if it would have been a lot of work (lazy me;)

Meanwhile, you can check this link (*alpha1). Hope it will be all fine?…

‘media-geneva.ch/demos/bjs/chair/project-chair-alpha1.html’

Edit: Oopsie, season 2. Forgot to remove from the menu call. It should be ok now (11:53 CEST) with this link:
‘media-geneva.ch/demos/bjs/chair/project-chair-alpha1.html’

The fix on the distributed link will be on in a couple of hours from now.

Oh (thanks for your comment @Necips), you want to push me to my limits, do you?:wink: :cold_sweat:
Don’t say more or I will want to marry you :bride_with_veil: :wink:

1 Like

Sorry, still doesn’t work :d

I have an Uncaught ReferenceError: gui is not defined at project-chair-alpha1.html:1665

as per the above. Can you do a refresh just now…
Edit: Sry for the disturbance. These parts should have been worked and checked prior to this release (even in early alpha). Will work the corrective over the WE. Please let me know if you encounter any other issue with the updated (*alpha1) link.

The original link has now also been updated and should work:
‘media-geneva.ch/demos/bjs/chair/project-chair-alpha.html’

Hi @Guigoz,
Did you manage to see it now?. I just did an update including the settings and key binding info. It should work now.

Hi,
still not working :x

Hum, seriously?
Did you use the alpha1 link? I will remove it.
This should be the only link (and really should be working)
media-geneva.ch/demos/bjs/chair/project-chair-alpha.html

Edit: you might have to clean the cache. And if it doesn’t work, could you kindly share a SS?
Thanks and sry again for disturbance,

I opened it in private navigation window to be sure for the cache but no, still nothing :x

Interesting! Is this something you know about on a 4k monitor? It looks like the initial scale would be incorrect. This come on top of the other issue, because the other is solved I can assure you.
Now, I happened to copy this line of meta data while working some aspects of the mobile version:

‘meta name=“viewport” content=“width=device-width, initial-scale=1”’

May be I will try without this and ask you to kindly check on an alt version. Else, any input would be welcomed…

Can you see the GUI in my previous BJS demo?
‘media-geneva.ch/demos/bjs/snowball/psa.html’