Glass material problem

I have a part of the object (top cap) which should fully have a glass material. I’m using Physical material in 3ds max for it along with Babylon exporter. Transparency Mode is set to Blend, Base color texture is 8bit png with alpha. But I got some glass glitches in viewers and I cannot fix that in any way. I’m attaching screenshot with all of the settings and my result. Was looking for this problem everywhere in web, and seems like nobody faced with this or nobody created fully glass object? That’s very weird.
Will be glad to hear any thoughts.

pinging @Guillaume_Pelletier for his expertise/thoughts.

are you targeting .Babylon or .GLTF. If babylon did you try to uncheck hasVertexAlpha flag for the cap mesh

Sorry, forgot to mention, I’m exporting .glb file.

The alpha values may be inverted when using a physical material in 3dsMax, see this thread: 3dsMax exporter, Physical Material, and inverted alpha convention - #2 by Evgeni_Popov

Hi, Evgeni! Thanks for your input, but I think the problem here is not in texture. Even without any texture, if we simply change Transparency Weight from 0 to any other value, we got transparent material with same problems (glitches).

Hello, I read the conversation above and it help me with my work but my problem was, when I convert my file into glb babylon, the glass disappear and turn to fix color…NO transparency on it. HOw can I fix it?

just break the glass in-case of emergency

1 Like

Can anyone show the physical material setting and when it convert to glb file under babylon, the glass is intack?

Welcome aboard!

Are you able to setup a repro in the Playground, it will be easier to help?

If you need to host your assets: Using External Assets In the Playground | Babylon.js Documentation

Can you send a screenshot of the max material or attach your max scene? Maybe @Guillaume_Pelletier can help.

The documentation is here: How to export 3DS MAX scene as glTF | Babylon.js Documentation