Shell material with baked texture exports with transparency mode set to alpha blend


#1

Mesh with shell material looks like flipped polys. I can correct it in sandbox but i have too many materials. Anyone know how to set transparency mode to opaque in max?


#2

Adding @PatrickRyan and @kcoley


#3

@swavec are these docs on alpha mode for the 3ds Max exporter useful?

https://doc.babylonjs.com/resources/3dsmax_to_gltf#alpha-mode

If not, do you have a sample max scene which reproduces the issue?


#4

Also, are your meshes still flipped when using standardMaterial and not the Shell one?


#5

I dont have this option, im on max 2015, did i missed something installing exporter?


#6

@swavec do you mean the Alpha Test option? You will have to enable it by running the maxscript mentioned in the documentation.


#7

So i have figured that tga files always sets apha mode in baked texture to alpha blend. Changing it to opaque solves problem put i cant go thru all baked textures every time so i switched to jpg. But that works only halfway, because even that alpha is set to opaque it still exports alpha blend but if i go to that baked texture in material editor and do literaly nothing exept export again all is good. I have tested also png and same story.


#8

Also if you copy/paste texture into map slot, material is exportet in alpha blend mode. And again you need to open that texture settings and then it exports fine. So the problem is not baking it is when texture is paste / insertet .


Max exporter dont export meshes with multi materials in shell slot?
#9

This works. Thank you!

Hopefully they fix this soon.