Glb transparency mystery

in this glitch Glitch :・゚✧

when I go into the debugger and fix the scaling (set each node of the house to 1000)

when I rotate around the house, from some angles it’s transparent

I tried turning on and off backface culling and it didn’t appear to fix it

is there some other setting I should be looking at

front, darker:

back, way lighter looks like stuff disappeared

You have blended enabled in your material:
image
In the .glb file:
image
If transparency is what you expected but the sorting of faces is wrong, you can try to enable depth pre-pass on the material:
image

Hi There,

I’m going back to this. I changed the transparency mode, and the alpha mode, and tried all the depth functions settings; nothing seems to be fixing this problem.

It’s so odd, it almost looks like the house just changes color when I look at it from a certain angle, to more white. Are there other things that I should be trying?

When I make it opaque, it looks great, but gotta get this transparency working, and never had this kind of a problem before.

Thank you!

So, what do you want to achieve: the house should stay transparent and you should see the different layers of walls by transparency?

If yes there’s no ideal solution, see this doc that explains problems with rendering transparent objects and some solutions to it (one you can try is using facet sorting - see at the end of the doc).