GUI Editor bug from naming/id on duplicates?

I was setting up a PG to check on the best option to use navMeshes for stairs colliders.
Thought I would quickly use the Editor to make a simple interface.

Found that from some (fairly) recent changes, there are now issues accessing duplicate controls by name.
I noticed that when you duplicate a control, it now comes with a fancy name at first. Because these are now to be unique, right? and that’s fine. So, I changed the name, but next thing I noticed is that I’m unable to access this duplicate control by its name. Also, even on the first control created, when reloading the PG, I eventually get a not found error through its uniqueID (see SS and PG below).
This doesn’t happen with previous version snippets from the Editor. So it must come from the new way duplicates/copies are generated/written.

1 Like

I see you used an .obj instead of a .glb. I am learning and wondering was it the software you use that helped you decide on the choice, or for another reason?


Oh, yes. I used c4d. The choice is ‘emotional’ if I can say so :wink: :wink:. For many years and among all, cinema4D has been my favorite. However, I think I’m currently making my last personal project using c4d and the old (like me :wink: :older_adult:) obj format :smiling_face_with_tear:. Too many constraints, too heavy, …just outdated. I don’t have the same level of skills in Blender yet. I also don’t like the interface and approach as much but I guess it is today the best choice for modelling for BJS (and webGL in general). Another time, another era :hourglass_flowing_sand:

1 Like

Thanks @mawa. :handshake:

@mawa I can not seem to be able to repro with your pg :frowning:

Can you share the broken version ?

It is not easy to switch from C4D to Blender, the latter often seems to be counterintuitive for user (even despite the fact that Blender became much better in 3.xx version).
But why do you need to export to OBJ? Cinema4D has very good GLTF exporter.

Yes, but for that I would need to acquire the new version license :wink: :money_mouth_face:
I’m a bit short on resources for that as of just now :smiling_face_with_tear:

Did you try uncomment lines #176 and #177? These are copied controls and I checked the name multiple times. Whenever I try accessing these (as opposed to the ‘original’ controls) I get this error (see SS below)

Either I was very tired or something has changed from yesterday or there was an issue from the browser cache. I am certain that yesterday when copying a control, the name changed to a string (looked like a JSON). This morning, I tried again and the name of the duplicate does not change (but also doesn’t increment like I believe was said it would do??!) Anyways, I can now access my controls (again?). Something, just something must have happened. :thinking: :dizzy_face:

So if I understand well, there are no issues anymore @mawa ???

Huh, no. As weird as it is, there aren’t issues on my side anymore. Except I have been told by the GUI team that the copied controls would have a name that should increment and here it still doesn’t. But that might just come later or has been rethought. But, no, I’m fine. No issues as of just now :sweat_smile: (Although the user is always a potential issue :grin: :wink:)

1 Like