I updated from BJS 5.0-alpha.22 to 5.10.0 -- URL-quessing, OBJ-load / Set Chromium-antialias?

A) It was a bit of guessing to find all files I needed
like: https://cdn.babylonjs.com/materialsLibrary/babylon.shadowOnlyMaterial.min.js

B) My loaded OBJ/MTL was only partially visible. I could fix it by importing my OBJ in Blender and exporting it. The loader seems to be more critically now. I did not compare, what makes the difference in the OBJ, yet.

C) The parameter new Engine(… antialias) true/false makes a difference but less as it was in 5.0-alpha. It looks less nice and more Moiré Effects. – WRONG – I also did change from Firefox to Opera. And all Chromium based browsers are fast but “ugly”.
May be, they use a different default for WebGL? Could BJS check/set that default?


I wonder if somehow it does not end up in those fallback cases:

cc @RaananW ?

I am using an MacBook Air (x86)
Opera navigator.userAgent:
“Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_7) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/102.0.5005.115 Safari/537.36 OPR/88.0.4412.40”

FireFox navigator.userAgent:
“Mozilla/5.0 (Macintosh; Intel Mac OS X 10.15; rv:102.0) Gecko/20100101 Firefox/102.0”

Could it not be an Opera issue ? where they workaround the webkit issue by disabling antialiasing on their end ?

This would still not explain the Chromium issue but I can unfortunately not repro on my Mac intel based as well :frowning:

It is the same with Chrome.
You may try it here: OSM2World-ts

There is a visible difference between true and false for antialiasing with Chromium browsers
WebGL seems to have 3 options for antialiasing: off, week_fast, strong_slow (Firefox). May be it is as complicated as with shadows.

This query only supports safari when on desktops. Other browsers have their own rendering engines outside of iOS