Material colors not transferred from Blender

My colors are a mess and I decided to fix them by

  1. Changing colors in the Inspector to something I like
  2. Copy/paste the Hex values from Inspector to Blender
  3. Re-export the scene as a .babylon file.

Surprisingly the colors come out with completely different values when I look at them again in the inspector.

What I originally chose in the Inspector:
Diffuse - 38388B
Emissive - 677CB4

After typing these into the ‘Principled BSDF’ shader as Base Color and Emission, this is what got exported in the .babylon file:
Note that there is was no emissive color exported

What showed up in the Inspector next time around:
Diffuse: 0A0A41
Emissive: 000000

This is probably because you use pbr material and you would input colors in gamma space on some channels so it is not the color used by the material. You should use the scene recorder feature in the inspector: Applying Delta Changes To A Scene | Babylon.js Documentation

I am not using PBR materials, I have the PBR option turned off in the Blender Babylon exporter.

this sounds strange, could you share a repro ?

There is no emmissive on principled node. Check the mapping png on repo for how to work in emmissive.

This is not Blender 2.83 LTS. See Blender exporter development

No problem, I just set the emissive color in my Javascript after loading the model - which works great.
Thanks for writing the exporter, I think this is the best workflow available with Blender/Babylon.