Meshes from AssetContainer.instaniateModelsToScene() are translucent when a glowlayer is added to the scene

Continuing the issue from this thread, I’m having similar issues with the Mesh/Imported models being translucent when I use (AssetContainer).instantiateModelsToScene(). How can I “fix” this? I’ve tried settings the emissiveColor and diffuseColor to black, and adding the instantiated model ((InstantiatedEntries).rootNodes[0]) to the glowlayer and I’ve also tried adding the root imported meshes ((AssetContainer).meshes[0]) to the glowlayer, but neither method works.

Did you try using .meshes[1] instead of .meshes[0] like I showed in the old thread? Otherwise a new playground would be super helpful to see what’s going on. :slight_smile:


Sorry for the late reply! I did some testing, and realized that I can’t use (AssetContainer).meshes, since the models are instantiated to the scene and not added. After doing some testing, I’ve found that adding (InstaniatedEntries).rootNodes[0] to the glowlayer fixes it. Thanks!

1 Like