NME - optimalization warnings are not disappearing

The node target is set to Vertex but the warning disappears only after you save as unique URL. Or is this an intention?
Thank you!

It is the intention because else is not obvious when looking at the graph that this node will be in the vertex shader (as it is connected to a node on the fragment side of the house)

Can you please have a look at this NME?
Open the uvTwirl frame. Most of the nodes were flagged as promoted when I added the custom frame. (it would be cool to have the flag in the frame header also) I’ve explicitly set them to target Vertex. The warnings were still there. I’ve saved the graph. All of the flags has disappeared except one, the Add (y) node even though that node is set to target Vertex.

@Evgeni_Popov do you mind having a look into into it ?

@roland Sorry, I don’t understand what to do to repro / what is the problem in the last link you provided? Here’s what I see when I open the frame:

@Evgeni_Popov Hello!
Why is the Add node still flagged as promoted even though I set it to Vertex? I did it to all to others and the flag has disappeared on all of them, just the add Node (right corner) is still flagged.

  1. I opened a new node material in the editor and added an existing custom frame
  2. nodes got flagged because of automatic promotion
  3. I set all the targets to Vertex (I believe it is the moment when the flag should disappear but it doesn’t)
  4. I saved the NME to URL
  5. All nodes got back to normal (without the promotion flag) only the Add node is still saying that it was promoted automatically to target Vertex even though it was saved as target Vertex.

Hopefully this sounds more clearer :vulcan_salute:

Thank you!

Could you provide a link corresponding to step 1 from your explanations?

Hi @Evgeni_Popov!
I couldn’t reproduce the the original issue. Only the Add block is still marked with as promoted. Expand the uvTwirl custom frame and there is an Add block in the lower right corner. It is marked despite it is set to target Vertex

Another small issue I’ve found: The following material uses the FragCoord NME block. The blocks got promoted to Vertex but the FragCoord block can be used only in a fragment shader. There is a FragCoord block used in the Screen position custom frame.

Thank you!

I think it is what is expected: that’s because you set it to Vertex and by default it would have been created in the fragment that it is marked (and so the user can visually know that this block is not in the stage it would have been by default). @Deltakosh can you confirm it’s the expected behaviour?

I think this one is ok because you have a clear error message that explains the problem. It’s on the user to correct the problem. It’s not really possible to prevent this from happening as you can change the target of any block (or so), and depending on your changes this will make the fragCoord change its own target.

Thank you!


1 Like