Node editor preview shows 'Please wait, loading...'

So this is not happening to me on load (which is what I assume you are doing)

But going to put an issue on this for me to look into! Simple quick fix just edit any property on any node and it should update.

Or you can also simply change the mesh in the preview and change it back.

1 Like

Can you share any messages you got from your f12 console?

So I updated the code refresh after files/frames are loaded.

Please re-ping if you have more details though. :slight_smile:

If I choose plane, sphere and custom, it just shows the mesh. but when i choose cube, cylinder, shader ball, it shows loading div. And nothing in the chrome console

Use babylonjs: “4.2.0-beta.10” babylonjs-node-editor: “4.2.0-beta.10” in my react.js project. but i can’t import the babylonjs-node-editor module in my project. I don’t know if this is causing the problem.

Are you testing that online? Just to be sure - try hard-reloading the site ) to avoid caching issues). It is working well for me.

Also the fixes might be only available in beta 16, you should try to upgrade ?

I tried several times, but still has this problem.

The beta 16 seems not solve the problem

@msDestiny14, could you double check ???

And the color picker cannot move smoothly.

I guess is the package babylonjs-node-editor not be imported that causes this problem?

I run online and do not see the problem. You are using this in an independent project?

Yes, I use this in my independent project.

"devDependencies": {
    "@types/classnames": "^2.2.10",
    "@types/loadable__component": "^5.13.0",
    "@types/react": "^16.9.43",
    "@types/react-color": "^3.0.4",
    "@types/react-dom": "^16.9.8",
    "@types/react-router-dom": "^5.1.5",
    "@types/spark-md5": "^3.0.2",
    "monaco-editor-webpack-plugin": "^2.0.0",
    "typescript": "^3.9.7"
  "dependencies": {
    "@ant-design/icons": "^4.2.2",
    "@babylonjs/core": "4.2.0-beta.16",
    "@babylonjs/gui": "4.2.0-beta.16",
    "@babylonjs/loaders": "4.2.0-beta.16",
    "@babylonjs/materials": "4.2.0-beta.16",
    "@babylonjs/post-processes": "4.2.0-beta.16",
    "@babylonjs/procedural-textures": "4.2.0-beta.16",
    "@blueprintjs/core": "^3.30.0",
    "@blueprintjs/select": "^3.13.5",
    "@jiaminghi/data-view-react": "^1.2.4",
    "@loadable/component": "^5.13.1",
    "@testing-library/jest-dom": "^4.2.4",
    "@testing-library/react": "^9.3.2",
    "@testing-library/user-event": "^7.1.2",
    "@types/lodash": "^4.14.162",
    "@types/react-lazyload": "^2.6.0",
    "@types/spark-md5": "^3.0.2",
    "antd": "^4.5.1",
    "axios": "^0.20.0",
    "babylonjs": "4.2.0-beta.16",
    "babylonjs-gui": "4.2.0-beta.16",
    "babylonjs-inspector": "4.2.0-beta.16",
    "babylonjs-loaders": "4.2.0-beta.16",
    "babylonjs-materials": "4.2.0-beta.16",
    "babylonjs-node-editor": "4.2.0-beta.16",
    "babylonjs-post-process": "4.2.0-beta.16",
    "babylonjs-procedural-textures": "4.2.0-beta.16",
    "babylonjs-serializers": "4.2.0-beta.16",
    "cannon": "^0.6.2",
    "classnames": "^2.2.6",
    "earcut": "^2.2.2",
    "echarts": "^4.9.0",
    "echarts-for-react": "^2.0.16",
    "lodash": "^4.17.20",
    "node-sass": "^4.14.1",
    "re-resizable": "^6.6.1",
    "react": "^16.13.1",
    "react-app-rewired": "^2.1.6",
    "react-color": "^2.18.1",
    "react-dom": "^16.13.1",
    "react-monaco-editor": "^0.40.0",
    "react-router-dom": "^5.2.0",
    "react-scripts": "3.4.1",
    "spark-md5": "^3.0.1",
    "worker-loader": "^3.0.3"

I have just deployed version 17 in case smthg weird happened in 16.

could you check with it ? all the babylon related package should be using 17.

ohhhhhhhh also why using both the es6 packages and the none es6 ones ? this could create weird conflicts you should either only use the @babylonjs ones or the babylonjs- ones

and the node editor by default will be pulled according to the version of the engine you are using:

/** Define the Url to load node editor script */
    public static EditorURL = `${Engine.Version}/babylon.nodeEditor.js`;

I upgrade to beta 17 and removed the @babylonjs ones, still nothing changes…

could you share a repro project ???

This sounds really weird as it is pulling the js online which are the same as the one from the playground where we can not repro. I suspect it might be related to a special setup of your material

The project is belongs to our compony. So i cannot share it. I will try to repo this problem in another project.

1 Like