Opaque mesh rendering as if its alpha blended by the renderer

This one set of meshes I exported from 3ds max has a weird rendering quirk where it render opaque meshes as if they were alpha blended; that means faces which should be obscured by other faces of the same mesh, get rendered anyway, as if z sorting is not done. No opacityTexture present, alpha set to 1 (default), alphaMode set to 2 (default)

What could be the cause of this? Corrupt 3d models? Some flag I could switch in BABYLON.Mesh? Thanks in advance,

Are you sure all faces are treated as opaques? Maybe there are multiple materials and one is transparent?

That’s hard to tell more without a repro we can use to dig a bit more.

Thanks for the reply. There is only one material, and even if I remove it (mesh.material = null), the same behavior is maintained.

Anyway I might have found the cause. Vertex colors were also exported from 3ds max, and apparently they have an alpha channel as well, and it’s a tiny bit unintuitive to remove them in 3ds max.

1 Like