Scaling Transform Nodes in Havok: Issues with Mesh and Physics Body Synchronization

I’m currently facing a challenge while working with Havok. My task involves importing an external mesh into my project, and I’ve encountered difficulties in simultaneously scaling the geometry and the physics body to maintain consistent behavior. Initially, I attempted to scale the mesh followed by the creation of the physics body. However, this approach resulted in the physics body not being scaled accordingly. Additionally, when I tried scaling the physics body directly, I encountered problems where the physics body intersects with the ground, leading to a scenario where half of the body is above the ground while the other half is below.

Has anyone experienced similar issues or knows of a straightforward method to accurately scale both the geometry and the physics body in Havok, ensuring that all behaviors remain correct and synchronized?

Attached images demoing the problem (this is after the mesh is scaled and the same scale is applied to the when creating the PhysicsShapeCylinder)


IIRC, I think PluginV2/Havok supports change of scaling during simulation.
did you set disablePreStep to false for the physics body?
Do you have a small playground that mimics what you want to achieve?
cc @carolhmj

after scaling the box intersect with the ground, disablePreStep didn’t help

I’ve fixed a few things in your PG.
like mass for box for example.
Now, the box properly falls on the ground if placed high enough
and when placed and colliding with the ground, Havok will move it to eliminate collision.

so I can I set a scaled static object on the ground?

setting a mass of 0 or making it static means…it’s static :slight_smile: It will stay where it’s placed.