SSAO2 .textureSamples has no effect in v4.2?


Looks like SSAO2RenderingPipeline property .textureSamples has no effect in version 4.2. There are jaggies regardless number of samples (see image below). Version 4.1 provides almost no artifacts. There are no jaggies w/o ssao.

This is a repo:
Change the engine version to see how it changes.

Can I make something to remove the jaggies?


pinging @CraigFeldspar

Hello @val,
Since you use prepassRenderer (last param set to false), the imageprocessingpostprocess texture must be multisampled.
In other terms, you have to use this :

scene.enablePrePassRenderer().samples = 4;

@deltakosh I think we should add this in the doc and/or do something with the prepass post process when SSAO2’s textureSample property is altered

1 Like

I agree for the doc ! cc @PirateJC

Thank you @CraigFeldspar for your response. Yeah, it does the magic. Thank you again for your time!

P.S. Your new Doc guys is really 5-stars. Thanks!

Hey All, happy to update the appropriate doc if you can help me understand what you’d like added and where.

I assume this is the doc we’re talking about? Using the SSAO Rendering Pipeline | Babylon.js Documentation


So far, there is no SSAO2 described in that section. Perhaps, said addition should be made in the API section.

Probably @CraigFeldspar can give you better answer.

Thank you.

The existing API section is:

And the text is something like this:
“Note: it has no effect when parameter .forceGeometryBuffer is set to false in the constructor. Use BABYLON.Scene.enablePrePassRenderer().samples = 4 to enable multi-sampling.”

1 Like

Adding @RaananW for guidance on this as I believe the API docs are all automatically generated.

Actually this should be automated, setting it should update the prepass in prepass mode, I ll update the pipeline to do that.

1 Like