WebGL warning: uniform1i: This uniform location corresponds to a different program

i get this warning alot and especially when trying to implement
an babylon text input into my scene as soon as i try write something in the box
screen start to blink and console.log gives this message several times
is there a workaround or am i doing something wrong again?
and its not reproducable in PG
in PG everything works perfect but when i try onn my localhost setup

Are you sure you are relying on the latest version of the library in both cases ?

Also are you using the same browser in both cases ?

im not sure i ended up deleting everything and it worked so must be something in the
code i noticed, where do i see the version number on my babylonjs?
its kind of funny cuz i ended up doing all my code in the playground~
And if i try the same scene in angular i get tons of errors.
Its doable but the problem i face is silly i guess. and no its not same browser
i use chrome in PG and firefox in localhost

You can use BABYLON.Engine.Version: Babylon.js Playground

so my question is this too old?
from what i remember Pg is 4.0?

Well without a repro I can’t tell:) perhaps it is fixed in 4.0

yes i want 4.0 now. but i dont know how to get it =) its only 3.3.0 in npm what i can see

Here we are:

ok installeed =)

I think its the right direction
but now my ide cant find the GUI subclass so i stop for today but i installed 40017 alpha

Did you make sure to also get babylonjs-loaders v4.0?

ye i tried but my classes are messed up cuz earlier
BABYLON.GUI.AdvancedDynamicTexture was a class.
Now it cant find anything with GUI
I tried loaders too but no luck
In PG the class exist though so i dont really know where i went wrong…

Well it is tough to help you without more info. How is your project configured?

yeah thanks for all help but i tried even to run everything from cdn
BABYLON.GUI returns undefined even with cdn… sigh
so i maybe need to install 3.3.0 again
but its annoying that GUI exists in the PG so i dont know what is wrong
the npm package locally doesnt install all my classes?
i cant tell if its me or anything else right now but thanks for trying help me=)