Clear coat breaks shader in ios

If I turn on clear coat in the latest couple of betas and try looking at the scene in both safari and chrome on iOS 12.2 the material is completely white.

It was working earlier, for example my gto 67 demo work on iOS.
So there must be something that has broken it lately.

Pinging @sebavan

Looking into it now.

Would you have a repro ??? Babylon.js Playground works fine for me on ios.

This actually works fine as well on my phone: Babylon Labs - Car

I am on IOS 12.2 as well this is pretty strange. Could somebody else try the both previous URLs on IOS ? just to see if we got some consistent results

Here is a new demo I’m working on which has the problem.

After loading the model, I enable the clear coat using

this.bodyMaterial = scene.getMaterialByID('Body') as PBRMaterial
this.bodyMaterial.clearCoat.isEnabled = true
this.bodyMaterial.clearCoat.intensity = 0.5

But as soon as I do this, it stops working on both my iphone and ipad, in both chrome and safari.

I can see if I can reproduce it with a playground instead for easier debugging.

It would be awesome if you can cause my guess is it results from a material property combination so would need the exact same setup to repro.

@Leon would be amazing if we could have the repro next week so that it could be fixed before the 4.0 release :slight_smile: Thanks a lot in advance and sorry to bother with that but I can not figure the broken combination here :frowning:

I have been unable to reproduce the problem when only working with the model, so it must be something else in my setup causing the problem.

I’ll let you know if I find something, but otherwise we can close this and blame my incompetence :wink:

1 Like

Do not hesitate to share it online so I can take a look :slight_smile: if that helps.