Sandbox default texture sampling in images is terrible

I just tried an export from blender to .glb with a simple model and a few simple textures.

By default the sandbox selects the “Linear/Nearest & linear mip” This seems to cause terrible artifacts around all my edges of colors making them wobble and pixelate. There is no stitching happening here of uv islands , this is one uv island.

If I change it to another sampling method like ““Nearest/Linear & nearest mip” the issue is fixed ( some others fix it as well”

Look at this gif , notice the button areas ( black circles with white stroke… ) The bad looking one is the default sandbox sample I just mentioned:

ps . the diffuse is 4k so something is wrong here. also there is no break in geometry in those areas , they are planar faces.

i will still check it in a normal babylon engine load , I was just was doing a test in the sandbox and saw this and thought I better report it as it cant be right im sure.


chat soon

If sampler data are defined in the .glb file, Babylon is using them. If not, the spec says that one is free to use any value and Babylon is using mag=linear, min=linear and mipmap=linear. If you see “Nearest/Linear & nearest mip” it must be that your glb defines the sampler this way. Have you tried to display your file in another gltf viewer?

i never knew about setting sampling in .glb export from blender? I will google about it and report back

The default i got for all textures with this model in the sandbox is :

“Linear/Nearest & linear mip”

this is the one that does not render well ,exported from blender 2.91

Strangely I just tested some older models , ones I never had issues with before and exported from older blender version and to my surprise they import with different filtering, they default to :

“Linear and linear mip”

Which looks great as expected

So something in blender or blender export changed , or it is a material setup thing … let me see if I can get down to the bottom of this.

chat soon

Not related but honestly I find your tone pretty mean.
You are either shocked or you find things terrible.

I would clearly recommend you to remember that there are humans being the project and they could be hurt by how you present things.

yes apologies I did respond in the other thread , and cleared things up, well to that extent at least

I provide more info for this one as I did dig into it some more and found there were no such options exposed in the blender exporter , no way to set the desired sampling

So from a debugging point of view , the same latest online sandbox ( meaning same babylon version) gave different sample modes for models exported from different versions of blender. So there is that.

But additionally I loaded the problem model into a older version of a babylon scene locally and when loading up the inspector in that scene I found it only had two listed samples choices for texture sampling, so much less than the sandbox and it was not the same choice as sandbox anyway.

Of coarse I just fixed it by looping the textures and changing it to something that looked better.

It was just a case of something weird is going on

Anyway apologies to you and all the team and other users, i honestly did not set out to provoke or use bad tone and register intentionally, was just a mode swing or something i guess.

You guys do great work , treat all well and the community is great :wink:

1 Like

No worries @shaderbytes, we all have rough days (or nights:))

Thanks for your kind words!