Scene default lighting

The below example having good lighting even after disabling the light. my export file doesn’t show in this way after export. me too using scene.createDefaultEnvironment(); as well intensity. but mesh glows only when light falls on it. is there anyway.I m not using default light as I m using blender export glb file with lights. lights are working properly but when i off lights using debuger, its totally black.

As far as I can say based on your words.

  1. Check your file in Sandbox and see if everything is OK.
  2. Here the environment is commented, and when you turn off the spotlight, everything will be black since there is no light there anymore.
  3. Seems that you may have some problems with your environment or its texture. Environment is actually the light source; when one uses it, it is possible not to use lights at all.
  4. Would be helpful to see your example in Playground in order to find the exact answer. Here is the documentation how to use your assets in PG - Using External Assets In the Playground | Babylon.js Documentation

Go @labris Go !!! thanks a lot for your great answers :wink:

1 Like

Thank you for your detailed explnation.

1 Like