Texture Artifacts

Hello everyone,

I have encountered some texture artifacts with a scene having only a cube/box in and a PBR material with a texture on it. As you can see on the screenshot below:

These artifacts were so far reproducible only on a intel iris XE graphic card.
There artifacts are only visible if texture is applied on the pbr material.
Since I cannot directly test my scene on this graphic card, it is a bit difficult to isolate the issue.

Normally the cube is supposed to look like the pic below:

What do you think is causing these artifacts?

In case anyone is able to test on a intel iris XE graphic card please let me know so I can create a playground for you.

Any idea is welcomed.

Thank you, and I look forward to any possible idea for it.

Regards,
Gerald

Hmmm that’s a pretty new card so it might be some bugs not ironed out :confused: Sadly I don’t have any means to test too but I hope someone else here on the forum can

Its an integrated Intel Iris graphics chip. But it is still weird that the artifacts are there.

I hope someone has an idea or knows why it might be happening.

Thanks.

Can you share in a playground the scene you are rendering ? as the pattern is pretty weird and I d like to check the setup ?

Thanks for your response.

Unfortunately I can’t share the exact same scene where the screenshot was taken.

The scene is just a simple Box and a PBR material with a texture applied to it.
These artifacts have been so far only encountered on a HP ProBook i5 with an integrated intel iris XE graphics card.

I can provide you with such a simple playground as described above:
https://playground.babylonjs.com/#6CKRDV#1

I hope you are able to test on this specific graphic card and see that the artifacts are there.

I hope there is a solution or a workaround for this.

Thank you.

I can not test against the specific device bug you could try opening a chromium bug as it sounds driver specific here.

In the meantime could you try this PG https://playground.babylonjs.com/#6CKRDV#3 ? and if it still fails, simply removing the bump map ?

Thanks for the suggestion,

I am waiting for feedback until that is tested on that graphic card and then I’ll let you know.

Hi @sebavan,

So, setting noMipmapOrOptions to true and anisotropicFilteringLevel to 1 in the bump texture solves the issue. Meaning there are no artifacts but the texture does look sharp since it has no mipmaps.

Is there a way to disable the mipmaps other than in the Texture constructor?

Also, is there a way to fix the artifacts without having to disable the generation of mipmaps and setting the anisotropic to 1?

Thank you.

If it is a driver bug there won t be anyway but reporting it to the chromium team :frowning:

But first could you try without aniso ( = 1) but with mip maps ? to see if the issue is in the mip maps or aniso ?

I have actually so far tried the following test cases:

  1. Mipmaps and aniso = 4. Result: artifacts.
  2. Mipmaps and no aniso. Result: artifacts.
  3. No mipmaps and aniso = 1. Result: no artifacts.
  4. No mipmaps and no aniso. Result artifacts.
  5. Mipmaps and aniso = 1. Result: artifacts.

So, it seems like both properties play a role here.

In case there is no solution I might try to report it to the chromium team as you suggested.

Thanks.

Normal maps are normally not mipmaps friendly :slight_smile: as you can not simply average colors for mipmaps.

I know chromium recently released a gpu based mip mapping algorythm and I wonder if it could impact on your specific hardware. It is definitely worth reporting to them.

So,

I got feedback from the guy who could test on the graphic card.
I tried the following cases:

  1. No mipmaps, aniso = 4
  2. Mipmaps, aniso = 4

On both cases the artifacts were visible.

Below you can find some screenshots for comparison.

  1. No mipmaps, aniso = 4 (intel iris XE):

No mipmaps, aniso = 4 (other gpu) - No artifacts:

  1. Mipmaps, aniso = 4 (intel iris XE):

    Mipmaps, aniso = 4 (other gpu) - No artifacts:

Let me know if you got any idea about it.
Thanks.

Looks to me like you would have enough here to report a bug for this GPU/drivers.
In fact, I would have a solution but I don’t think you will like it: Get a real graphic card and drivers not carved in a garage by a student :grin:

Well, it was supposed to be one, right? :smiling_face_with_tear: But unfortunately, new releases come with their share of problems. I hope it’s fixed soon, I’m always eager to see more competition on the graphics card market :smile:

1 Like

Thanks for the responses guys :joy:,

I think I will report it as a bug.

:sunglasses:

Yup it looks like the only solution unfortunately.