WebApp from the Editor is not running on Chrome

Hi!
I’ve built and deployed the basic cube scene from the editor to a server.

https://editor-test.babylonjs.xyz/

It fails to run in Chrome however it runs in Firefox without problems.

logger.js:43 BJS - [14:06:33]: Error: FRAGMENT SHADER ERROR: 0:481: 'sampler2DShadow' : No precision specified
ERROR: 0:496: 'sampler2DShadow' : No precision specified
ERROR: 0:525: 'sampler2DShadow' : No precision specified
ERROR: 0:737: 'sampler2DShadow' : No precision specified
ERROR: 0:786: 'sampler2DShadow' : No precision specified
ERROR: 0:791: 'sampler2DShadow' : No precision specified
ERROR: 0:796: 'sampler2DShadow' : No precision specified

There seems to be another problem running the built application on Chrome reported by @ZzMarmot here (no issues on Firefox):

Can you guys help here?

Thank you!

Hey there! :grin: The sampler2D issue was a browser breaking change fixed in 4.2.1 and 5.x versions. I think editor might be using 4.2.0, @julien-moreau is that right?

2 Likes

Hello, I use FireFox and it works well.

1 Like

Yup cause 4.2.1 is meant to fix a Chrome issue only, you should update to it.

1 Like

@sebavan I’m not using the Editor at all so it’s not an issue for me. I was just trying to help @ZzMarmot to solve his problem, created a quick test and ran into the shader issue. However this topic can be valuable for the others experiencing the same problem.
Thank you!

2 Likes

Hey how I can update the babylon version of the editor? I have the same problem in chrome or chromium based browsers Autito

Hey @Lozamded
I think you don’t need to update the version of the editor but more the one you are using in the project.
Simply set the version of all « @babylonjs » dependencies in the package.json file of the project to 4.2.1 and then reinstall dependencies using « npm i »

Don’t forget to rebuild the project (npm run build or CRTL+b in the editor)

The editor already uses 4.2.1

1 Like

Thanks I will try it

1 Like

Let me know if it works for you :slight_smile:

Its work =D thanks a lot

1 Like

hey @julien-moreau
I have tried to change those dependencies in the package.json to 4.2.1, but it seems like i couldn’t install them. it was just stucked and reported (cached miss).
I went to the github page and found there is just 4.2.0 version of the editor. Should upgrade the babylonjs version to higher version?
wish for your reply! thank you

Hey, I just fixed it. It seems like it was my network problem, Thank you so much!

1 Like