WebAssembly error (HAVOK project) in Old iOS Device (iPhone 6s)

Good afternoon team.

I´m playing with a project using HAVOK, in general it works correctly on all the devices that I have been testing.

On an iPhone 6s (iOS 15.7.5) and on an iPad Mini 2 I have found that it does not load and shows the following error when logging with Chrome:

2 Likes

Doesnt work on my iphone 13 either

cc @Cedric
I know there were a few issues with wasm and old devices, but I will let him reply when he is back.

1 Like

Seems like a compiler bug on apples end, or the wasm is using some unsupported feature like esm import refs

That is more strange. I am testing it on an iPhone 12 running iOS 16.4.1 and it works perfectly on both Safari and iOS

Hmm, i am on 16.3 il upgrade and see

Works now using 16.4.1. Cool

2 Likes

I was about to say it. Typical apple crap :slight_smile:

4 Likes

i’ll quote you on that :wink:

1 Like

You can :slight_smile: I’m fed up with their BS

3 Likes

Literally me testing on old Apple devices

scrolling-monkey

Abc Yes GIF by The Bachelorette

1 Like

The problem is that Android is the third world country of devices :slight_smile: I WANT MY WINDOWS PHONE!

2 Likes

Let´s port BJS to Symbian and let’s start a new era of eco-resilient technology :joy:

2 Likes

Lol!!!

After several attempts testing the Havok physics demos on different devices, I can confirm that the same error occurs on iOS devices with system versions < 16.

1 Like

Apple wasm support in Safari is quite erratic. We’ve found different behavior with different iOS version. Some SIMD instruction get broken after a few seconds of use (I guess it’s the optimized transpiled version that is buggy compared to the interpreted one).
We do (and will continue to) our best to test and find workarounds when suitable. Apple is not helping, for sure.

1 Like

Hi @Cedric!
Thanks for your response

It’s a pity, although I have no doubt that you will find a good solution.

Regarding Apple, I have no doubts in what you say

Meanwhile I think the solution would be to continue working with the V1 Cannon or Ammo

@Cedric is there a solution for this apart from switching to v1?

Unfortunately no.
If you want to use Havok, make sure to have users to use the expected iOS/Safari version.
Or rely on V1 for more compatibility…but less performance.

2 Likes