Webgpu error in Chrome, but not Chrome Canary for beta 8

I have an active Chrome WebGPU Experiment running for my production environment, but locally I can only test in Chrome Canary.
In Chrome Canary it works locally, and also in production. In Chrome I have the errors below in production.
I made sure to download the latest twgsl and glslang files from preview.babylonjs.

The Babylon playground also doesn’t have WebGPU in regular Chrome as far as I can tell.
So this is really hard for me to test/understand right now.
I hope you can help me with this.

https://tuggowar.io/webgpu is the production environment with webgpu
It all worked on the beta 6 by the way.

Hi @mise!

Are you sure it worked in Chrome? As far as I know it currently works only in Chrome Canary. I don’t follow the updates so just asking :slight_smile:

Up to date Chrome:

Chrome Canary:

Chrome is lagging compared to Chrome Canary regarding the WebGPU spec implementation. On our side, we always try to keep in sync with the latest updates of the spec and the implementation in Chrome Canary, so it’s expected it may fail in Chrome depending on the updates.


So the webgpu flag may be present in one version of Chrome and removed by an update later?

It’s possible, they had removed this flag in Canary in some version… But you can still start Chrome with --enable-unsafe-webgpu to overcome this problem.

The problem with Chrome vs Chrome Canary is that Chrome does not implement the latest changes in the spec. For eg, my Chrome version is “98.0.4758.82” whereas my Canary version is “100.0.4887.0”. I think Canary is several weeks (maybe months) ahead of Chrome so is more up to date regarding the implementation of WebGPU.

1 Like

Thank you!

thanks for educating me! I encourage you to stay as ahead as you can :wink:
sorry to keep you so busy today :no_mouth:

I still am not sure how to version control the changing glslang.* and twgsl.*
do you have a good suggestion for this? can I for example always take the latest because it is backward compatible? or do I need the right version for each specific Babylon release?

bah, I cannot get it fixed even by rolling back the before mentioned files and beta 5 or 6.

I think this means a Chrome update messed things up right?

Yes, you can always take the latest versions for both.

Yes, that’s probably the reason. The spec is still evolving and it’s a work in progess, being an early adopter has some disavantages :slight_smile:

1 Like