Can I make 1 to 1 unity export (lightmap)?

Hi, I’m trying the unity toolkit and get a very different result in lightbaked model:

Can I get a closer look to the one on unity?

This is definitely a question for @MackeyK24 the mastermind behind the exporter.

Lighting it not a 1 to 1 thing. I export as much as I can from unity lighting and try to re implement with Babylon toolkit lighting… scaling intensity and color to match as close as possible

If you package up the scene and send to me I will take at look at making them match as close as possible

1 Like

Thank you Mackey, will package scene and let you have it. Another question (if possible), I was trying to load the generated gltf in separate project, but it complains : “Require extension CVTOOLS_babylon_mesh is not available”.

reference: Require extension CVTOOLS_babylon_mesh is not available

Any idea on that one?

The culprit was a difference in ambient light colour. Set it white in unity (general settings script) and got it look very similar!

Yo @franmx … Put color back… and use the babylon inspector… find Ambient Light node and set its level from 0.5 to 1.0

I may just need to crank up the default intensity for the ambient light…

Try that before having to result to scaling the color from the original authored ambient color…

let me know how that looks

1 Like

Thanks a lot, that’s it!

For now, Create a empty game object… Add a Default Scene Controller component and under lighting options… Set Ambient Intensity = 1.0 (Or whatever you want)

Right now Ambient Intensity defaults to 0.5 … I may change that to 1.0 as default

I think that would be useful for the non-initiated (like me).

After review… the 0.5 seems best fit for default intensity (without lightmap). But you can adjust that if you need to try and match unity lighting with lightmap.

Got it Mackey, makes sense. Thanks.